Contact Center
Incident Report for groundworks
Resolved
This incident has been resolved.
Posted Sep 19, 2024 - 15:40 EDT
Investigating
We are currently investigating this issue.
Posted Sep 19, 2024 - 13:50 EDT
This incident affected: RingCentral (Contact Center).