Contact Center
Incident Report for groundworks
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 10:05 EDT
Investigating
We are currently investigating this issue.
Posted Sep 13, 2024 - 09:45 EDT
This incident affected: RingCentral (Contact Center).