Office for the web Service Status
Incident Report for groundworks
Resolved
This incident has been resolved.
Posted Dec 13, 2024 - 15:20 EST
Investigating
We are currently investigating this issue.
Posted Dec 13, 2024 - 14:15 EST
This incident affected: Microsoft (Office for the web Service Status).