Connect Platform
Incident Report for groundworks
Resolved
This incident has been resolved.
Posted Sep 13, 2024 - 16:15 EDT
Investigating
We are currently investigating this issue.
Posted Sep 13, 2024 - 15:35 EDT
This incident affected: RingCentral (Connect Platform).